Back
Downtime

Clearbenchmark App is offline
Started 30 Oct at 08:07pm GMT, resolved 30 Oct at 08:59pm GMT.
Portal
Resolved
The web app has now fully recovered
Posted 30 Oct at 08:59pm GMT.

Updated
Cloudflare seem to be recovering slowly. The Clearbenchmark App is back online, however with extremely degraded performance. We will continue to monitor the situation.
Posted 30 Oct at 08:27pm GMT.

Created
We use cloudflare to provide the Clearbenchmark App to our customers. Currently, Cloudflare have an ongoing incident which is out of our control but is preventing the Clearbenchmark App from loading at all.
We are continuing to monitor the situation and will provide more of an update as and when we have it.
Posted 30 Oct at 08:07pm GMT.